First time here? You are looking at the most recent posts. You may also want to check out older archives or the tag cloud. Please leave a comment, ask a question and consider subscribing to the latest posts via RSS. Thank you for visiting! (hide this)

UPDATE: My DNS have now been updated, email seems to be working fine, also from Exchange servers, sorry again for any problem that might have caused.

If you sent me an email in the last days and you got an error back, please try it again now in a few day, or contact me on twitter @simonech. Same problem happened if you contacted my through the contact page of my blog.

Also, if you are sending emails through an Exchange server (like if you are from Microsoft) you probably got a similar DNS error since the beginning of December: I'm really sorry for this and please sent the me your email again, and I'll try to answer it immediately.

If you are interested in why that all happened continue reading...

Why that all happened

During last autumn I decided I would have discontinued my WebHost4Life account

to moved everything to Linked Labs: websites, blogs and DNS. And I also decided to move all the domain registrations I had shattered around various registrars and hosters to the same one, the one I already used to register my .it domains: Aruba.

I thought that moving sites was difficult, but transferring a domain to another host is even more: the biggest problem is when you cannot afford to have a single moment without having the correct DNS records for your domain, especially for your email service to keep on working.

I had to contact Aruba via a support ticket to ask them to pre-configure the DNS with my records, because they change the authoritative NS to they own (instead of keeping the old ones) and they don't let you do it yourself before the domain has been successfully transferred to them. They probably screwed something up, and I was not able to receive emails from people sending from Exchange.

I discovered this problem just before Christmas, and yesterday, when I finally had time to sit down and try to fix the problem I asked them to move the authoritative NS to the one of Linked Labs, which is holding all my other DNS records. The problem is that they immediately deleted all my DNS records on their servers (piyosailing.com is not working either). This wouldn't have been a problem if the NS change was done automatically upon the request from the admin tool. Unfortunately for me it seems like NS changes have to be manually approved. So, as result, I'm without email for the weekend because, obviously, their support team is not working on weekends.

I hope everything goes back to normal in few days. Sorry for the problems

Tags: ,,
posted on Sunday, January 10, 2010 3:46 PM

Comments on this entry:

# re: Public Service Announcement: email not working (or why Aruba sucks)

Left by Humano at 2/7/2010 8:30 PM

Hello, i wite you affter the how did you and what can be done to get aruba change the dns records; i,m transfering my domain from aruba,it, i was with them for years and have had many problems with their services (got hacked from turks, many of their links in control panel does not work, bad support, many scripts problems, specially on installing cms, wordpress..., endless; and affter a week of daily tickets to their support* i,ve got the epp/auth code to initiate the transfer process, but i,m still catched with the dns records, and so my questions are: will the records update from selves once my domain time services expires on aruba(by the end of this month feb.2010) to the ones where i transfered the domain?, is there any authoritie/support to wich i can explain/complain this issue?; i would apretiate any infos you can give me, thank you

Comments have been closed on this topic.