First time here? You are looking at the most recent posts. You may also want to check out older archives or the tag cloud. Please leave a comment, ask a question and consider subscribing to the latest posts via RSS. Thank you for visiting! (hide this)

bug

There are 5 entries for the tag bug

Entity Framework 4.3.1 Migrations and non English locale

A few days ago I started migrating a web app I was working on from ASP.NET MVC 3 and EF4 to ASP.NET MVC 4 and EF 4.3.1. All went well, except for some problems with the automatic generation of the DB scheme using EF Code First: it was creating the database, but no tables and not even the __MigrationHistory table added in 4.3; and during the execution of the schema generation an error was raised with a weird datetime conversion error. I tried this both on SQL Express 2005 and SQL Compact and I got the same outcome, just different...

Only parameterless constructors and initializers are supported in LINQ to Entities

Back from the holiday an nice surprise was awaiting for me: I’ve to “finalize” (as in make it work) an application that someone that left the company developed more than one year ago. Among the other problems one real surprised me: the project is built with .NET 3.5 and uses Entity Framework v1 and in some the queries failed with the following strange error: Only parameterless constructors and initializers are supported in LINQ to Entities. Just to be clear, it was a runtime error, not a build failure. The queries that were failing...

How to solve the “Visual Studio vanishing” bug of ASP.NET MVC P5

The latest release of ASP.NET MVC had a weird bug: with Visual Studio 2008 SP1, when you open any view page, Visual Studio just vanishes, with no error dialog displayed. The Application log contains an item with the following error message: .NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (6AFD0F92) (0) With a bit of trial and error, and thanks to some other posts and comments I found out that the reason for this is some conflict with the Visual Studio PowerCommands tool: uninstalling it fixes the problem. In my previous installation,...

Feedburner kills all-time stats... no, wait, it was only an error

This weekend, while checking my RSS stats on FeedBurner I noticed that the "all time" option of RSS subscribers was gone. This thing raised a nest of hornets, with some bloggers accusing Google not to communicate with users, other looking for alternatives, and yet other offering hacks to download the historical data. The official forum was full of people asking for an explanation since last Saturday. On Monday Steve Olechowski, Product Manager of FeedBurner, posted a comment saying it was a bug and would have been fixed in the next code update, and the same was done on...

When the case matters: VS2008 hot-fix bug

A few days ago I installed the VS 2008 Web Development Hot-Fix Roll-Up but yesterday I found a strange bug: when I wanted to create a "new web site" I had an empty dialog, with no project templates and all the field disabled. On the original post I found a comment from someone with the same problem and ScottGu told him to send him an email: I did the same, Scott answered in a few hours saying that someone will have handled the issue. A few hours later I got an email from Mikhail Arkhipov from...