First time here? You are looking at the most recent posts. You may also want to check out older archives or the tag cloud. Please leave a comment, ask a question and consider subscribing to the latest posts via RSS. Thank you for visiting! (hide this)

The latest release of ASP.NET MVC had a weird bug: with Visual Studio 2008 SP1, when you open any view page, Visual Studio just vanishes, with no error dialog displayed. The Application log contains an item with the following error message:

.NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (6AFD0F92) (0)

With a bit of trial and error, and thanks to some other posts and comments I found out that the reason for this is some conflict with the Visual Studio PowerCommands tool: uninstalling it fixes the problem.

In my previous installation, I found out that uninstalling and reinstalling the TFS Power Tools fixes the problem as well.

Technorati Tags: ,,
posted on Wednesday, October 15, 2008 3:31 PM

Comments on this entry:

# re: How to solve the “Visual Studio vanishing” bug of ASP.NET MVC P5

Left by Chris Sutton at 10/15/2008 6:46 PM

I have the same here. I did a lot of testing and it has always come down to uninstalling PowerCommands to fix this crashing/error.

Interestingly I get the crash on Websites, but not with WAPs in VS 2008.

Chris Sutton

# re: How to solve the “Visual Studio vanishing” bug of ASP.NET MVC P5

Left by Yazılım at 10/16/2008 6:23 PM

Thanks for clearing this issue. Been struggeling with it for couple of days. Now i know why it happens.

Comments have been closed on this topic.