First time here? You are looking at the most recent posts. You may also want to check out older archives or the tag cloud. Please leave a comment, ask a question and consider subscribing to the latest posts via RSS. Thank you for visiting! (hide this)

A month after my first try, yesterday I tried again. I started at 8:30pm stopping all useless programs (RSS Readers, Outlook, Skype, Gtalk, MSN Messenger and all that sort of stuff). Then I stopped almost all window services running, and cleaned all the temp folders (one of which still contained some stuff - 430Mb -  remaining from the other try).

Ready, set, go!!!

15 minutes for the patch to extract itself to a temp folder, then other 10 minutes for the MSI to configure itself. Finally I get the "Do you want to install the Service Pack 1 for Visual Studio 2005..."? I click yes and I go and watch the sunset (yes, in NZ the sunset is at 9pm :-)) and drink a good glass of NZ Pinot Noir (well, actually more than one :-)) with Nic and his wife Leonie, which are hosting me in their lovely house till I find my own.

Two hours and half after I launched the installation I get a popup saying that it needs some more space to continue with the process. Well, it's funny since I had almost 2Gb available on the disk before starting: I move a folder on another drive and then everything works fine. And at 11:30pm, 3 hours since the beginning, I had the SP1 installed on my laptop.

Then today, I decided to install the SP1 also on my machine at work, on Vista. I launched it this afternoon before leaving from work. I hope tomorrow morning everything will be fine, so that I can install, as suggested by some, also the Visual Studio 2005 SP1 Update for Windows Vista Beta.

Here are some links that explain better the problem I had during the installation:

 

PS: as you may have noticed, with this post I started to use the XFN stuff available in the WLW plugin package available on CodePlex and the XFN relationship addin for Subtext.

posted on Monday, January 15, 2007 11:12 PM

Comments on this entry:

# re: Two SP1 in two days

Left by Eber Irigoyen at 1/17/2007 5:19 AM

so the installation consumed the 2GB?

how much RAM do you have?

# re: Two SP1 in two days

Left by Simone at 1/17/2007 1:39 PM

2GB only during the installation, then, at the end, all the space was free-ed again (well... almost all)

I've got 1Gb or RAM, but an "old" P4 2,7Mhz and I've VS2005 Team Suite

# re: Two SP1 in two days

Left by Adam at 2/4/2007 10:51 AM

Tip:

Always run these type of installs silently. It helps to know what a huge patch like this does as far as Windows Installer goes.

This specific patch has to load the whole thing into memory in order to validate its integrity. It does this twice; once during the UI and once during installation.

I ran the SP1 installer and it took about 40 minutes start to finish on a mediocre laptop (1.7Ghz Pentium M, 1GB RAM, sufficient disk space) under a silent install.

# Visual Studio 2005 SP1 Update for Vista available

Left by CodeClimber at 3/7/2007 1:12 PM

Visual Studio 2005 SP1 Update for Vista available

Comments have been closed on this topic.